summaryrefslogtreecommitdiff
path: root/wsrep/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'wsrep/CMakeLists.txt')
-rw-r--r--wsrep/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/wsrep/CMakeLists.txt b/wsrep/CMakeLists.txt
index 53c8e853078..ff2bdec4def 100644
--- a/wsrep/CMakeLists.txt
+++ b/wsrep/CMakeLists.txt
@@ -15,6 +15,10 @@
SET(WSREP_SOURCES wsrep_gtid.c wsrep_uuid.c wsrep_loader.c wsrep_dummy.c)
+IF(NOT WITH_INNOBASE_STORAGE_ENGINE)
+ MESSAGE(WARNING "WSRep is enabled, but innodb is not. This configuration is not supported")
+ENDIF()
+
ADD_CONVENIENCE_LIBRARY(wsrep ${WSREP_SOURCES})
DTRACE_INSTRUMENT(wsrep)