summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2020-01-29 19:10:51 -0800
committerDavid Lord <davidism@gmail.com>2020-01-29 19:10:51 -0800
commit92486d009f9288e916baafdf5a9b0741694e5d64 (patch)
treeb20ddadf8ee543dc8a277a5499411552d4f7ca3c /setup.py
parentf46ae22f04986dfafdf37d003992928146702584 (diff)
downloadmarkupsafe-92486d009f9288e916baafdf5a9b0741694e5d64.tar.gz
drop Python 2.7, 3.4, 3.5 support
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 2 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 8f9476a..f8eec16 100644
--- a/setup.py
+++ b/setup.py
@@ -12,9 +12,6 @@ from setuptools import find_packages
from setuptools import setup
from setuptools.command.build_ext import build_ext
-with io.open("README.rst", "rt", encoding="utf8") as f:
- readme = f.read()
-
with io.open("src/markupsafe/__init__.py", "rt", encoding="utf8") as f:
version = re.search(r'__version__ = "(.*?)"', f.read()).group(1)
@@ -60,12 +57,9 @@ def run_setup(with_binary):
"Issue tracker": "https://github.com/pallets/markupsafe/issues",
},
license="BSD-3-Clause",
- author="Armin Ronacher",
- author_email="armin.ronacher@active-4.com",
- maintainer="The Pallets Team",
+ maintainer="Pallets",
maintainer_email="contact@palletsprojects.com",
description="Safely add untrusted strings to HTML/XML markup.",
- long_description=readme,
classifiers=[
"Development Status :: 5 - Production/Stable",
"Environment :: Web Environment",
@@ -73,8 +67,6 @@ def run_setup(with_binary):
"License :: OSI Approved :: BSD License",
"Operating System :: OS Independent",
"Programming Language :: Python",
- "Programming Language :: Python :: 2",
- "Programming Language :: Python :: 3",
"Topic :: Internet :: WWW/HTTP :: Dynamic Content",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Text Processing :: Markup :: HTML",
@@ -82,7 +74,7 @@ def run_setup(with_binary):
packages=find_packages("src"),
package_dir={"": "src"},
include_package_data=True,
- python_requires=">=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*",
+ python_requires=">=3.6",
cmdclass={"build_ext": ve_build_ext},
ext_modules=ext_modules if with_binary else [],
)