summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2018-05-04 07:37:47 -0700
committerDavid Lord <davidism@gmail.com>2018-05-04 07:46:55 -0700
commitb7a31f5f151a3641975df1b113573947efe923a8 (patch)
treeed36b41fcdae730b66fd3fd11d16eed8dae806b9 /setup.py
parentf6a491d9348597e67e3bed5f4d0ff3cbf38857e3 (diff)
downloadmarkupsafe-b7a31f5f151a3641975df1b113573947efe923a8.tar.gz
add sphinx docs, update docstrings
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3b6f4d3..6cf59ef 100644
--- a/setup.py
+++ b/setup.py
@@ -67,7 +67,7 @@ def run_setup(with_binary):
author_email='armin.ronacher@active-4.com',
maintainer='Pallets team',
maintainer_email='contact@palletsprojects.com',
- description='Safely add untrusted strings to XML/HTML markup.',
+ description='Safely add untrusted strings to HTML/XML markup.',
long_description=readme,
classifiers=[
'Development Status :: 5 - Production/Stable',
@@ -92,6 +92,12 @@ def run_setup(with_binary):
'pytest',
'coverage',
'tox',
+ 'sphinx',
+ 'pallets-sphinx-themes',
+ ],
+ 'docs': [
+ 'sphinx',
+ 'pallets-sphinx-themes',
],
},
packages=['markupsafe'],