summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2020-02-25 18:09:05 -0800
committerdormando <dormando@rydia.net>2020-02-26 00:16:50 -0800
commit05721e4b6c393f25830021bb13f6637e5747dfcc (patch)
tree533ac96420a55842798070ee225a4ca32d39febc /Makefile.am
parent379e3df46dd2f08fb12f577bba70a9d7422b6f7c (diff)
downloadmemcached-05721e4b6c393f25830021bb13f6637e5747dfcc.tar.gz
add separate limits for connection buffers
allows specifying a megabyte limit for either response objects or read buffers. this is split among all of the worker threads. useful if connection limit is extremely high and you want to aggressively close connections if something happens and all connections become active at the same time. missing runtime tuning.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 1f848cc..0d30161 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ noinst_PROGRAMS = memcached-debug sizes testapp timedrun
BUILT_SOURCES=
-testapp_SOURCES = testapp.c util.c util.h stats_prefix.c stats_prefix.h jenkins_hash.c murmur3_hash.c hash.c hash.h
+testapp_SOURCES = testapp.c util.c util.h stats_prefix.c stats_prefix.h jenkins_hash.c murmur3_hash.c hash.c hash.h cache.c
timedrun_SOURCES = timedrun.c
@@ -18,7 +18,7 @@ memcached_SOURCES = memcached.c memcached.h \
thread.c daemon.c \
stats_prefix.c stats_prefix.h \
util.c util.h \
- trace.h cache.h sasl_defs.h \
+ trace.h cache.c cache.h sasl_defs.h \
bipbuffer.c bipbuffer.h \
logger.c logger.h \
crawler.c crawler.h \
@@ -27,11 +27,6 @@ memcached_SOURCES = memcached.c memcached.h \
authfile.c authfile.h \
restart.c restart.h
-if BUILD_CACHE
-memcached_SOURCES += cache.c
-testapp_SOURCES += cache.c
-endif
-
if BUILD_SOLARIS_PRIVS
memcached_SOURCES += solaris_priv.c
endif