summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2014-04-16 23:13:04 -0700
committerdormando <dormando@rydia.net>2014-04-16 23:20:21 -0700
commit05ca809cc4bda62f0c778be29bfdf565fa39142d (patch)
treecaaa069af4a731988f0d00cee92c804ce307617d /Makefile.am
parentd5d4c4909f37b9ec157bb418fa821530dfb66c9f (diff)
downloadmemcached-05ca809cc4bda62f0c778be29bfdf565fa39142d.tar.gz
Make hash table algorithm selectable
jenkins hash is old. Lets try murmur3 to start! Default is the old one, so people aren't surprised.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 70be448..ba39e60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,8 @@ timedrun_SOURCES = timedrun.c
memcached_SOURCES = memcached.c memcached.h \
hash.c hash.h \
+ jenkins_hash.c jenkins_hash.h \
+ murmur3_hash.c murmur3_hash.h \
slabs.c slabs.h \
items.c items.h \
assoc.c assoc.h \