summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiovanni Bechis <giovanni@paclan.it>2017-08-30 17:59:55 +0200
committerdormando <dormando@rydia.net>2017-11-04 13:07:28 -0700
commit105064c8a6ab98177a73355b72b489e69a2f98e8 (patch)
treef80bfda6484a5bacc1c36dbc7ca94f3843658a5c /Makefile.am
parent7f4e0246e5c27baa9a7a690e5905f5ee56b80ece (diff)
downloadmemcached-105064c8a6ab98177a73355b72b489e69a2f98e8.tar.gz
Rework pledge support after seccomp support has been added
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b6db4db..95c334c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,6 +38,10 @@ if BUILD_LINUX_PRIVS
memcached_SOURCES += linux_priv.c
endif
+if BUILD_OPENBSD_PRIVS
+memcached_SOURCES += openbsd_priv.c
+endif
+
if ENABLE_SASL
memcached_SOURCES += sasl_defs.c
endif