summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2017-07-26 12:00:39 -0700
committerdormando <dormando@rydia.net>2017-07-26 12:00:39 -0700
commit24ca3d89b0e3fd2e4a11301ae3f37ee872567620 (patch)
tree3aeaae0e316d506f1544fe32de026c9f86fda091 /Makefile.am
parent24368e645f37cf7513865c3aa76e67158fbb37e9 (diff)
downloadmemcached-24ca3d89b0e3fd2e4a11301ae3f37ee872567620.tar.gz
PARALLEL=9 make test -> runs prove in parallel
would prefer to pass/reuse make's -j down to prove, but don't want to spend the time on it. makes tests run in ~30s instead of several minutes. can use a fair amount of RAM so be wary with automated builders.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 36933ea..a5a0930 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,7 +83,11 @@ MOSTLYCLEANFILES = *.gcov *.gcno *.gcda *.tcov
test: memcached-debug sizes testapp
$(srcdir)/sizes
$(srcdir)/testapp
- prove $(srcdir)/t
+ @if test -n "${PARALLEL}"; then \
+ prove $(srcdir)/t -j ${PARALLEL}; \
+ else \
+ prove $(srcdir)/t; \
+ fi
@if test `basename $(PROFILER)` = "gcov"; then \
for file in memcached_debug-*.gc??; do \
mv -f $$file `echo $$file | sed 's/memcached_debug-//'`; \