summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2022-02-24 19:22:52 -0800
committerdormando <dormando@rydia.net>2022-02-24 22:34:33 -0800
commit2a903f04d1b395cd60c1b7357a9b733e19eb7973 (patch)
tree781e0544c035f590c0727aebbb52e129777af5e1 /Makefile.am
parenta7b83d36ff7c6bbdb7783d352bb056554c83efcd (diff)
downloadmemcached-2a903f04d1b395cd60c1b7357a9b733e19eb7973.tar.gz
proxy: add ring_hash builtin
this is ketama-based, with options for minor compat changes with major libraries. does _not_ support weights. The weights bits in the original ketama broke the algorithm, as changing the number of points would shift unrelated servers when the list changes. this also changes backends to take a "name" specifically, instead of an "ip address". Though note if supplying a hostname instead of an IP there might be inline DNS lookups on reconnects.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cb10dbf..6db916b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,7 +57,8 @@ memcached_SOURCES += proto_proxy.c proto_proxy.h vendor/mcmc/mcmc.h \
proxy_await.c proxy_ustats.c \
proxy_jump_hash.c proxy_request.c \
proxy_network.c proxy_lua.c \
- proxy_config.c
+ proxy_config.c proxy_ring_hash.c \
+ md5.c
endif
if ENABLE_EXTSTORE