summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStanisław Pitucha <viraptor@gmail.com>2017-06-13 22:06:43 +1000
committerdormando <dormando@rydia.net>2017-08-23 23:59:11 -0700
commit304b77e4ef6ac4402b214bc4e94397b4a7838fd5 (patch)
tree2ebe42193698c5913be1dada2fb8106e18eabf17 /Makefile.am
parentfef33aac21a11b25e9f8ac517f089c0d484ea499 (diff)
downloadmemcached-304b77e4ef6ac4402b214bc4e94397b4a7838fd5.tar.gz
Move -lseccomp to LDADD
Order in the compilation matters. Some compilers will fail with -lseccomp before the objects.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e56fbf9..b6db4db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,7 +36,6 @@ endif
if BUILD_LINUX_PRIVS
memcached_SOURCES += linux_priv.c
-LDFLAGS += -lseccomp
endif
if ENABLE_SASL
@@ -53,6 +52,11 @@ memcached_DEPENDENCIES =
memcached_debug_DEPENDENCIES =
CLEANFILES=
+if BUILD_LINUX_PRIVS
+memcached_LDADD += -lseccomp
+memcached_debug_LDADD += -lseccomp
+endif
+
if BUILD_DTRACE
BUILT_SOURCES += memcached_dtrace.h
CLEANFILES += memcached_dtrace.h