summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2022-02-18 15:19:09 -0800
committerdormando <dormando@rydia.net>2022-02-18 16:13:52 -0800
commit34e0359d4de223d8cde4166f7d10ae352d7ebfdf (patch)
tree041a57edfb4bb3b58aa23498681295cb71789ee5 /Makefile.am
parentd85c379d74d92f8e9bd7ccf1ca57520f485a24f0 (diff)
downloadmemcached-34e0359d4de223d8cde4166f7d10ae352d7ebfdf.tar.gz
proxy: pull chunks into individual c files
now's a good time to at least shove functional subsections of code into their own files. Some further work to clearly separate the API's will help but looks not too terrible. Big bonus is getting the backend handling code away from the frontend handling code, which should make it easier to follow.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e2c1bd8..cb10dbf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -52,7 +52,12 @@ memcached_SOURCES += sasl_defs.c
endif
if ENABLE_PROXY
-memcached_SOURCES += proto_proxy.c proto_proxy.h vendor/mcmc/mcmc.h
+memcached_SOURCES += proto_proxy.c proto_proxy.h vendor/mcmc/mcmc.h \
+ proxy_xxhash.c proxy.h \
+ proxy_await.c proxy_ustats.c \
+ proxy_jump_hash.c proxy_request.c \
+ proxy_network.c proxy_lua.c \
+ proxy_config.c
endif
if ENABLE_EXTSTORE