summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-03-10 08:35:34 -0700
committerDustin Sallings <dustin@spy.net>2009-03-10 12:59:07 -0700
commit44ec7ca57dd9241e178d65001105b7d100a7dd50 (patch)
treea5af9a50aae378db9344977265c1efd145df86aa /Makefile.am
parenta45621053bc744a1cfc4b2c3732e26b8046a9044 (diff)
downloadmemcached-44ec7ca57dd9241e178d65001105b7d100a7dd50.tar.gz
Created a tool to show us the sizes of various data structures.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 79e960d..ab4c26c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-bin_PROGRAMS = memcached memcached-debug
+bin_PROGRAMS = memcached memcached-debug sizes
pkginclude_HEADERS = protocol_binary.h
BUILT_SOURCES=
@@ -58,7 +58,8 @@ EXTRA_DIST = doc scripts TODO t memcached.spec memcached_dtrace.d
MOSTLYCLEANFILES = *.gcov *.gcno *.gcda *.tcov
-test: memcached-debug
+test: memcached-debug sizes
+ $(srcdir)/sizes
prove $(srcdir)/t
@if test `basename $(PROFILER)` = "gcov"; then \
for file in memcached_debug-*.gc??; do \