summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2021-05-03 19:08:02 -0700
committerdormando <dormando@rydia.net>2021-06-09 16:02:14 -0700
commit79d996979824ca974188fc589ed52f6fc0b21aeb (patch)
tree6d832f3d384187284b6f8e1a3974a34e285bf98a /Makefile.am
parent4481e4c831dc79058f9ce83046e1d6c53f14b912 (diff)
downloadmemcached-79d996979824ca974188fc589ed52f6fc0b21aeb.tar.gz
hash: add XXH3 to list of hash algorithms.
needs more testing. in a "pure miss" test to help show hashing overhead, with four worker threads and large ascii multigets there is a measurable performance boost for longer keys. Very short keys (10-15 bytes) are about even. for 150ish byte keys 12m rps -> 13m rps roughly. Not too bad! need to test hash table distribution for large sets of keys before merging. need to consider if worth switching the defaults now or later.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cf4b31c..9b17bc7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
bin_PROGRAMS = memcached
-pkginclude_HEADERS = protocol_binary.h
+pkginclude_HEADERS = protocol_binary.h xxhash.h
noinst_PROGRAMS = memcached-debug sizes testapp timedrun
BUILT_SOURCES=