summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTharanga Gamaethige <tgamaethige@netflix.com>2020-05-13 15:46:57 -0700
committerdormando <dormando@rydia.net>2020-07-01 13:55:36 -0700
commit7e64232119cd182f43617e628e660dc75b7bb411 (patch)
tree58fa9f07a6fe3b999459d7286a6e85e21961daf4 /Makefile.am
parent7c2df4a70d3aa50dd507ee92a0af4e0279433988 (diff)
downloadmemcached-7e64232119cd182f43617e628e660dc75b7bb411.tar.gz
fixing the basic tls test so it exits correctly when fails
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d62facf..a0d5900 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -114,8 +114,8 @@ test_tls:
test_basic_tls:
@if test $(SSL_TEST)1 != 1; then \
echo "Running basic tests with TLS"; \
- $(builddir)/testapp; \
- prove $(srcdir)/t/binary.t $(srcdir)/t/getset.t $(srcdir)/t/ssl*; \
+ $(builddir)/testapp && \
+ prove $(srcdir)/t/binary.t $(srcdir)/t/getset.t $(srcdir)/t/ssl* && \
echo "Finished running basic TLS tests"; \
else \
echo "Set SSL_TEST=1 to enable TLS tests"; \