summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKanak Kshetri <kanakkshetri@fastmail.fm>2019-12-13 02:40:14 -0600
committerdormando <dormando@rydia.net>2020-01-13 17:45:49 -0800
commit8acec7694304b756f2f5b8b1665531d6afc7daf4 (patch)
treeb89aebd1c8ab9650f4329f53d419fb2d20c9f0c5 /Makefile.am
parent2fedca92a45926a7aeaeaab8853ce394b0727bbf (diff)
downloadmemcached-8acec7694304b756f2f5b8b1665531d6afc7daf4.tar.gz
stats: Move unit tests to testapp.c
* Remove bespoke testing system in favor of testapp.c * Change stats_prefix_init function to take prefix delimiter. Otherwise, we would have to include memcached.h in testapp.c to get the settings struct, which in turn would cause a conflicting definition of the conn struct.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a4a51c..43aecda 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ noinst_PROGRAMS = memcached-debug sizes testapp timedrun
BUILT_SOURCES=
-testapp_SOURCES = testapp.c util.c util.h
+testapp_SOURCES = testapp.c util.c util.h stats.c stats.h jenkins_hash.c murmur3_hash.c hash.c hash.h
timedrun_SOURCES = timedrun.c