summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2015-11-18 01:49:53 -0800
committerdormando <dormando@rydia.net>2016-06-16 17:14:34 -0700
commit916fff3609b7ab817513a1a8498795c9f740d0e0 (patch)
treee38dbb1ee69f7de94d4f2a9f71016dadd89567e2 /Makefile.am
parentcad0ecbf381ab9e4ea4af80a0e24b86167d1e2a5 (diff)
downloadmemcached-916fff3609b7ab817513a1a8498795c9f740d0e0.tar.gz
initial logger code.
Logs are written to per-thread buffers. A new background thread aggregates the logs, further processes them, then writes them to any "watchers". Logs can have the time added to them, and all have a GID so they can be put back into strict order. This is an early preview. Code needs refactoring and a more complete set of options. All watchers are also stuck viewing the global feed of logs, even if they asked for different data. As of this commit there's no way to toggle the "stderr" watcher.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index ba39e60..281e9af 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,9 @@ memcached_SOURCES = memcached.c memcached.h \
thread.c daemon.c \
stats.c stats.h \
util.c util.h \
- trace.h cache.h sasl_defs.h
+ trace.h cache.h sasl_defs.h \
+ bipbuffer.c bipbuffer.h \
+ logger.c logger.h
if BUILD_CACHE
memcached_SOURCES += cache.c
@@ -71,7 +73,7 @@ memcached_debug_dtrace.o: $(memcached_debug_OBJECTS)
SUBDIRS = doc
DIST_DIRS = scripts
-EXTRA_DIST = doc scripts t memcached.spec memcached_dtrace.d version.m4 README.md
+EXTRA_DIST = doc scripts t memcached.spec memcached_dtrace.d version.m4 README.md LICENSE.bipbuffer
MOSTLYCLEANFILES = *.gcov *.gcno *.gcda *.tcov