summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-03-09 11:52:25 -0700
committerDustin Sallings <dustin@spy.net>2009-03-26 11:55:26 -0700
commit923a335bf8613696d658448cd9c48a963924d436 (patch)
treec8f9f6e8fad4dcfb02e79574fb544ba8281766d0 /Makefile.am
parent496384caa61e4f577196db51aea259a642a27d4a (diff)
downloadmemcached-923a335bf8613696d658448cd9c48a963924d436.tar.gz
Use git's version number for releases.
This will allow more specific version numbers, while simplifying a proper release down to a tag and make dist. During development, ./version.sh needs to run periodically to update the version number. I'd recommend just adding a call to version.sh as a git post commit hook: % cat .git/hooks/post-commit echo "Updating version." ./version.sh (and make sure the file is executable)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4cf00b4..af41fe4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,7 @@ memcached_debug_dtrace.o: $(memcached_debug_OBJECTS)
SUBDIRS = doc
DIST_DIRS = scripts
-EXTRA_DIST = doc scripts TODO t memcached.spec memcached_dtrace.d
+EXTRA_DIST = doc scripts TODO t memcached.spec memcached_dtrace.d version.m4
MOSTLYCLEANFILES = *.gcov *.gcno *.gcda *.tcov