summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAli Saidi <alisaidi@amazon.com>2020-08-19 00:13:28 -0500
committerdormando <dormando@rydia.net>2020-10-27 17:54:21 -0700
commit9bb323ca3447421ee30ef26d1e48896d2d80b742 (patch)
tree85e42574ea1e877881d25ae35cdc1d4f6c754275 /Makefile.am
parenteb1bc72b9497e2c0e77d66740dc3053b6855a89a (diff)
downloadmemcached-9bb323ca3447421ee30ef26d1e48896d2d80b742.tar.gz
arm64: Re-add arm crc32c hw acceleration
Use the .arch_extension directive so that a config options and special cflags aren't required. Add a few tests for both the software and hardware implementations
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 8ea4841..8ce0c2c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ noinst_PROGRAMS = memcached-debug sizes testapp timedrun
BUILT_SOURCES=
-testapp_SOURCES = testapp.c util.c util.h stats_prefix.c stats_prefix.h jenkins_hash.c murmur3_hash.c hash.h cache.c
+testapp_SOURCES = testapp.c util.c util.h stats_prefix.c stats_prefix.h jenkins_hash.c murmur3_hash.c hash.h cache.c crc32c.c
timedrun_SOURCES = timedrun.c