summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2017-10-18 00:42:58 -0700
committerdormando <dormando@rydia.net>2017-11-28 14:18:05 -0800
commitcd2ce96754ef10926057dd76a203325c35384074 (patch)
treee2ff6c331a61887a43693a464b33601c56418e22 /Makefile.am
parent603c1bb32304b107b468dae00ef083de1189762f (diff)
downloadmemcached-cd2ce96754ef10926057dd76a203325c35384074.tar.gz
extstore: configure and start time gating
./configure --enable-extstore to compile the feature in specify -o ext_path=/whatever to start.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d1e4d60..27a2dac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,8 +24,6 @@ memcached_SOURCES = memcached.c memcached.h \
crawler.c crawler.h \
itoa_ljust.c itoa_ljust.h \
slab_automove.c slab_automove.h \
- extstore.c exstore.h \
- storage.c storage.h \
crc32c.c crc32c.h
if BUILD_CACHE
@@ -49,6 +47,11 @@ if ENABLE_SASL
memcached_SOURCES += sasl_defs.c
endif
+if ENABLE_EXTSTORE
+memcached_SOURCES += extstore.c extstore.h \
+ storage.c storage.h
+endif
+
memcached_debug_SOURCES = $(memcached_SOURCES)
memcached_CPPFLAGS = -DNDEBUG
memcached_debug_LDADD = @PROFILER_LDFLAGS@