summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorOla Jeppsson <ola.jeppsson@gmail.com>2019-10-08 20:19:14 -0400
committerdormando <dormando@rydia.net>2019-10-17 14:07:29 -0700
commitebfa600e23df19a29dc82a9ab308833641d3cdf4 (patch)
tree0b9db53919c6cd8b0a6ad8a4db3ff9b0bdc26142 /Makefile.am
parentbe0804cf3855cf968b3c6c0cc6e1f4b0724205a7 (diff)
downloadmemcached-ebfa600e23df19a29dc82a9ab308833641d3cdf4.tar.gz
Support running tests in out-of-tree build
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6eb6db0..3a4a51c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,7 +119,7 @@ test_tls:
test_basic_tls:
@if test $(SSL_TEST)1 != 1; then \
echo "Running basic tests with TLS"; \
- $(srcdir)/testapp; \
+ $(builddir)/testapp; \
prove $(srcdir)/t/binary.t $(srcdir)/t/getset.t $(srcdir)/t/ssl*; \
echo "Finished running basic TLS tests"; \
else \
@@ -128,8 +128,8 @@ test_basic_tls:
endif
test: memcached-debug sizes testapp
- $(srcdir)/sizes
- $(srcdir)/testapp
+ $(builddir)/sizes
+ $(builddir)/testapp
if ENABLE_TLS
@if test $(SSL_TEST)1 = 1; then \
$(MAKE) SSL_TEST=1 test_basic_tls; \