summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-08-14 23:06:06 -0700
committerDustin Sallings <dustin@spy.net>2009-08-14 23:06:06 -0700
commitfba0a8919dd24c9dafa9459e4b046a58649392e0 (patch)
tree56aeef44b414d3d43a526e8bf648795bd11d3381 /Makefile.am
parent50d7188502f635d41ca07bb1f7b666f7b54171f0 (diff)
downloadmemcached-fba0a8919dd24c9dafa9459e4b046a58649392e0.tar.gz
Put a time limit on memcached processes started from within tests.
This solves the problem where certain test failures would cause indefinite hangs as child processes refused to ever exit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 62fd1bf..76a6a03 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,13 @@
bin_PROGRAMS = memcached
pkginclude_HEADERS = protocol_binary.h
-noinst_PROGRAMS = memcached-debug sizes testapp
+noinst_PROGRAMS = memcached-debug sizes testapp timedrun
BUILT_SOURCES=
testapp_SOURCES = testapp.c util.c util.h
+timedrun_SOURCES = timedrun.c
+
memcached_SOURCES = memcached.c memcached.h \
hash.c hash.h \
slabs.c slabs.h \