summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2020-02-25 18:09:05 -0800
committerdormando <dormando@rydia.net>2020-02-26 00:16:50 -0800
commit05721e4b6c393f25830021bb13f6637e5747dfcc (patch)
tree533ac96420a55842798070ee225a4ca32d39febc /configure.ac
parent379e3df46dd2f08fb12f577bba70a9d7422b6f7c (diff)
downloadmemcached-05721e4b6c393f25830021bb13f6637e5747dfcc.tar.gz
add separate limits for connection buffers
allows specifying a megabyte limit for either response objects or read buffers. this is split among all of the worker threads. useful if connection limit is extremely high and you want to aggressively close connections if something happens and all connections become active at the same time. missing runtime tuning.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index e1fa597..376a131 100644
--- a/configure.ac
+++ b/configure.ac
@@ -466,7 +466,6 @@ fi
dnl ----------------------------------------------------------------------------
-AC_SEARCH_LIBS(umem_cache_create, umem)
AC_SEARCH_LIBS(gethugepagesizes, hugetlbfs)
AC_HEADER_STDBOOL
@@ -737,14 +736,6 @@ AM_CONDITIONAL([BUILD_LINUX_PRIVS],[test "$build_linux_privs" = "yes"])
AM_CONDITIONAL([BUILD_OPENBSD_PRIVS],[test "$build_openbsd_privs" = "yes"])
AM_CONDITIONAL([BUILD_FREEBSD_PRIVS],[test "$build_freebsd_privs" = "yes"])
-AC_CHECK_HEADER(umem.h, [
- AC_DEFINE([HAVE_UMEM_H], 1,
- [Define this if you have umem.h])
- build_cache=no
-], [build_cache=yes])
-
-AM_CONDITIONAL([BUILD_CACHE], [test "x$build_cache" = "xyes"])
-
AC_ARG_ENABLE(docs,
[AS_HELP_STRING([--disable-docs],[Disable documentation generation])])