summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2020-07-04 10:59:28 +0100
committerdormando <dormando@rydia.net>2020-11-02 14:24:27 -0800
commit0b374c63ab7e63c0098983d0a68cefedfd94557a (patch)
tree1f50c70cf575efe33107ffde1b57c8fcd094a9a6 /configure.ac
parent5d4785936e3e8937047daafd874c792668dc8528 (diff)
downloadmemcached-0b374c63ab7e63c0098983d0a68cefedfd94557a.tar.gz
illumos build fixes + require libevent2
libevent 1 doesn't have the socket id wrapper. since version 2 is 10 years old we should fail to build on version 1. explicit cast to avoid possible pedantic build flags complains (ie can be the old iovec interface)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a40b390..be2b460 100644
--- a/configure.ac
+++ b/configure.ac
@@ -388,6 +388,22 @@ if test $ac_cv_libevent_dir != "(system)"; then
fi
fi
+AC_RUN_IFELSE(
+ [AC_LANG_PROGRAM([
+#include <event.h>
+ ], [dnl
+const char *ver = event_get_version();
+return (ver != NULL && *ver != '1') ? 0 : 1;
+ ])
+ ],[
+ AC_DEFINE(HAVE_LIBEVENT_NEW, 1, [linked to libevent])
+ ],
+ [
+ AC_MSG_ERROR([libevent2 is required])
+ ],
+ []
+[])
+
trylibssldir=""
AC_ARG_WITH(libssl,
[ --with-libssl=PATH Specify path to libssl installation ],