summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2020-04-02 17:36:02 +0100
committerdormando <dormando@rydia.net>2020-04-10 17:23:16 -0700
commit651380cd4863033f4668f09c6a96819044e11f69 (patch)
treedb47f6d4c5448add31c8e25841c57d899d22fd80 /configure.ac
parent7bd7f6dc88f620ac77fe6b5acd5ffb06105c759d (diff)
downloadmemcached-651380cd4863033f4668f09c6a96819044e11f69.tar.gz
build: sasl build fix on FreeBSD
on some systems (e.g. FreeBSD), shared libraries do not contain symbols thus build failing for wrong reasons. here just trying to compile dumb code to check it instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 9 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0fd5c8d..3785d72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,10 +161,15 @@ if test "x$enable_sasl" = "xyes"; then
AC_C_DETECT_SASL_CB_GETCONF
AC_C_DETECT_SASL_CB_GETCONFPATH
AC_DEFINE([ENABLE_SASL],1,[Set to nonzero if you want to include SASL])
- AC_SEARCH_LIBS([sasl_server_init], [sasl2 sasl], [],
- [
- AC_MSG_ERROR([Failed to locate the library containing sasl_server_init])
- ])
+ AC_TRY_COMPILE([
+ #ifdef HAVE_SASL_SASL_H
+ #include <sasl/sasl.h>
+ #endif
+ ],[
+ sasl_server_init(NULL, "test");
+ ],[ENABLE_SASL=1
+ ],[ENABLE_SASL=0
+ ])
AS_IF([test "x$enable_sasl_pwdb" = "xyes"],
[AC_DEFINE([ENABLE_SASL_PWDB], 1,