summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2020-04-13 11:37:24 -0700
committerdormando <dormando@rydia.net>2020-04-13 11:37:24 -0700
commit82029ecc9b3dd0f57b3f9ab9761f44714cceed6f (patch)
treeef46e2d847aa640dbd9ac44deb7a302ba9225695 /configure.ac
parentd94d2379fd824eee5a75ea65128cf042916d5d2b (diff)
downloadmemcached-82029ecc9b3dd0f57b3f9ab9761f44714cceed6f.tar.gz
Revert "build: sasl build fix on FreeBSD"1.6.5
This reverts commit 651380cd4863033f4668f09c6a96819044e11f69.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 451b5ba..b192e60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -164,15 +164,10 @@ if test "x$enable_sasl" = "xyes"; then
AC_C_DETECT_SASL_CB_GETCONF
AC_C_DETECT_SASL_CB_GETCONFPATH
AC_DEFINE([ENABLE_SASL],1,[Set to nonzero if you want to include SASL])
- AC_TRY_COMPILE([
- #ifdef HAVE_SASL_SASL_H
- #include <sasl/sasl.h>
- #endif
- ],[
- sasl_server_init(NULL, "test");
- ],[ENABLE_SASL=1
- ],[ENABLE_SASL=0
- ])
+ AC_SEARCH_LIBS([sasl_server_init], [sasl2 sasl], [],
+ [
+ AC_MSG_ERROR([Failed to locate the library containing sasl_server_init])
+ ])
AS_IF([test "x$enable_sasl_pwdb" = "xyes"],
[AC_DEFINE([ENABLE_SASL_PWDB], 1,