summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-02-02 18:21:35 -0800
committerDustin Sallings <dustin@spy.net>2009-02-02 21:31:13 -0800
commit8e328be366d7b880b8c0ca8e204b01fa13252f5a (patch)
tree397727040c81b0eeec7a347f2cb2c1a8ce0f55fb /configure.ac
parentd9d189a2876ee09bfe5d28106bfa4ad0ae9494f4 (diff)
downloadmemcached-8e328be366d7b880b8c0ca8e204b01fa13252f5a.tar.gz
icc: Enable -Wall and -Werror
This produces a *lot* of remark output. Some if it is likely to be valuable (e.g. conversions) and some of it isn't (e.g. arg processing order not defined).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5257840..754490d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,7 +312,7 @@ dnl to detect the function ;-)
if test "$ICC" = "yes"
then
dnl ICC trying to be gcc.
- CFLAGS="$CFLAGS -diag-disable 187"
+ CFLAGS="$CFLAGS -diag-disable 187 -Wall -Werror"
elif test "$GCC" = "yes"
then
CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"