summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTrond Norbye <Trond.Norbye@sun.com>2008-10-06 13:07:34 +0200
committerDustin Sallings <dustin@spy.net>2009-01-03 00:09:12 -0800
commit91f3ce6e324c1639b1fba151be7ec8ea4cae5f94 (patch)
tree3e12c8b2060dea50b673c1d5e02551e7122cd59b /configure.ac
parentdf1b7e42959a9c055a7320a14fa5f80b4f22f6a8 (diff)
downloadmemcached-91f3ce6e324c1639b1fba151be7ec8ea4cae5f94.tar.gz
Add -Wall to gcc compilation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 78e5531..247e04d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,7 +233,7 @@ dnl the test program will generate a compilation warning and hence fail
dnl to detect the function ;-)
if test "$GCC" = "yes"
then
- CFLAGS="$CFLAGS -Werror -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
+ CFLAGS="$CFLAGS -Wall -Werror -pedantic -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls"
elif test "$SUNSTUDIO" = "true"
then
CFLAGS="$CFLAGS -errfmt=error -errwarn -errshort=tags"