summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2009-03-09 11:52:25 -0700
committerDustin Sallings <dustin@spy.net>2009-03-26 11:55:26 -0700
commit923a335bf8613696d658448cd9c48a963924d436 (patch)
treec8f9f6e8fad4dcfb02e79574fb544ba8281766d0 /configure.ac
parent496384caa61e4f577196db51aea259a642a27d4a (diff)
downloadmemcached-923a335bf8613696d658448cd9c48a963924d436.tar.gz
Use git's version number for releases.
This will allow more specific version numbers, while simplifying a proper release down to a tag and make dist. During development, ./version.sh needs to run periodically to update the version number. I'd recommend just adding a call to version.sh as a git post commit hook: % cat .git/hooks/post-commit echo "Updating version." ./version.sh (and make sure the file is executable)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 182b105..f3fa8b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,6 @@
AC_PREREQ(2.52)
-AC_INIT(memcached, 1.3.2, brad@danga.com)
+m4_include([version.m4])
+AC_INIT(memcached, VERSION_NUMBER, brad@danga.com)
AC_CANONICAL_SYSTEM
AC_CONFIG_SRCDIR(memcached.c)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)