summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2020-03-08 15:02:56 -0700
committerdormando <dormando@rydia.net>2020-03-08 15:02:56 -0700
commit936325b13c5fd354ce2820cec135755e7a13d092 (patch)
treeba4bd3df1c62f89000da8680817ffb8282b5ab4e /configure.ac
parent9c8a1f4766551e4b7760feba0dd175705669c9b8 (diff)
downloadmemcached-936325b13c5fd354ce2820cec135755e7a13d092.tar.gz
extstore: enable by default.1.6.0
links to a forwarder for the wiki page.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 376a131..f5b64fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,7 +86,7 @@ AC_ARG_ENABLE(arm_crc32,
[AS_HELP_STRING([--enable-arm-crc32], [Enable ARMv8 CRC32 instructions])])
AC_ARG_ENABLE(extstore,
- [AS_HELP_STRING([--enable-extstore], [Enable external storage EXPERIMENTAL ])])
+ [AS_HELP_STRING([--disable-extstore], [Disable external storage (extstore)])])
AC_ARG_ENABLE(seccomp,
[AS_HELP_STRING([--enable-seccomp],[Enable seccomp restrictions EXPERIMENTAL])])
@@ -190,7 +190,7 @@ if test "x$enable_dtrace" = "xyes"; then
fi
fi
-if test "x$enable_extstore" = "xyes"; then
+if test "x$enable_extstore" != "xno"; then
AC_DEFINE([EXTSTORE],1,[Set to nonzero if you want to enable extstore])
fi
@@ -209,7 +209,7 @@ fi
AM_CONDITIONAL([BUILD_DTRACE],[test "$build_dtrace" = "yes"])
AM_CONDITIONAL([DTRACE_INSTRUMENT_OBJ],[test "$dtrace_instrument_obj" = "yes"])
AM_CONDITIONAL([ENABLE_SASL],[test "$enable_sasl" = "yes"])
-AM_CONDITIONAL([ENABLE_EXTSTORE],[test "$enable_extstore" = "yes"])
+AM_CONDITIONAL([ENABLE_EXTSTORE],[test "$enable_extstore" != "no"])
AM_CONDITIONAL([ENABLE_ARM_CRC32],[test "$enable_arm_crc32" = "yes"])
AM_CONDITIONAL([ENABLE_TLS],[test "$enable_tls" = "yes"])
AM_CONDITIONAL([ENABLE_ASAN],[test "$enable_asan" = "yes"])