summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAli Saidi <alisaidi@amazon.com>2020-08-19 00:13:28 -0500
committerdormando <dormando@rydia.net>2020-10-27 17:54:21 -0700
commit9bb323ca3447421ee30ef26d1e48896d2d80b742 (patch)
tree85e42574ea1e877881d25ae35cdc1d4f6c754275 /configure.ac
parenteb1bc72b9497e2c0e77d66740dc3053b6855a89a (diff)
downloadmemcached-9bb323ca3447421ee30ef26d1e48896d2d80b742.tar.gz
arm64: Re-add arm crc32c hw acceleration
Use the .arch_extension directive so that a config options and special cflags aren't required. Add a few tests for both the software and hardware implementations
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index a7be211..a40b390 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,10 @@ AS_IF([test "$ICC" = "yes" -o "$GCC" = "yes"],
AS_IF(test "$CLANG" = "no",[CFLAGS="$CFLAGS -pthread"])
])
+dnl clang will error .arch_extension crc32 assembler directives to allow
+dnl assembling crc instructions without this
+AS_IF(test "$CLANG" = "yes",[CFLAGS="$CFLAGS -Wno-language-extension-token"])
+
if test "$ICC" = "no"; then
AC_PROG_CC_C99
fi
@@ -82,11 +86,6 @@ fi
AM_PROG_CC_C_O
AC_PROG_INSTALL
-dnl ARM crc32 optimization is disabled until we have hardware for an automated
-dnl regression test.
-dnl AC_ARG_ENABLE(arm_crc32,
-dnl [AS_HELP_STRING([--enable-arm-crc32], [Enable ARMv8 CRC32 instructions])])
-
AC_ARG_ENABLE(extstore,
[AS_HELP_STRING([--disable-extstore], [Disable external storage (extstore)])])
@@ -206,10 +205,6 @@ if test "x$enable_tls" = "xyes"; then
AC_DEFINE([TLS],1,[Set to nonzero if you want to enable TLS])
fi
-if test "x$enable_arm_crc32" = "xyes"; then
- AC_DEFINE([ARM_CRC32],1,[Set to nonzero if you want to enable ARMv8 crc32])
-fi
-
if test "x$enable_asan" = "xyes"; then
AC_DEFINE([ASAN],1,[Set to nonzero if you want to compile using ASAN])
fi