summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Carlier <devnexen@gmail.com>2019-10-01 11:13:07 +0100
committerdormando <dormando@rydia.net>2019-10-17 13:54:44 -0700
commitb24f9305669dd8514bbfe7b7479786356523e5f0 (patch)
tree052684206d940f5893c8098786a41cb727ef047c /configure.ac
parent1939cf9edc0656f7b1cfab6365f313b56b07a333 (diff)
downloadmemcached-b24f9305669dd8514bbfe7b7479786356523e5f0.tar.gz
DTrace build fix
During config step just being "contented" by generating the header, there is no symbols to attach for, no chance to work as is. Changing a probe signature, on some platforms, pthread_t is an opaque type thus casting to a type large enough to hold it for all oses.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fb78fc5..57fb7c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,12 +172,11 @@ if test "x$enable_dtrace" = "xyes"; then
if test "x$DTRACE" != "xno"; then
AC_DEFINE([ENABLE_DTRACE],1,[Set to nonzero if you want to include DTRACE])
build_dtrace=yes
- # DTrace on MacOSX does not use -G option
- $DTRACE -G -o conftest.$$ -s memcached_dtrace.d 2>/dev/zero
+ $DTRACE -h -o conftest.h -s memcached_dtrace.d 2>/dev/zero
if test $? -eq 0
then
dtrace_instrument_obj=yes
- rm conftest.$$
+ rm conftest.h
fi
if test "`which tr`" = "/usr/ucb/tr"; then