summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2021-07-29 17:31:08 -0700
committerdormando <dormando@rydia.net>2021-08-09 17:09:08 -0700
commitc25d0bd68ab0f6226c2d979bf0951923624926dd (patch)
treeee742afe391e8e47f43163bca32f91a284fdc4ef /configure.ac
parentd89ecd3456138c226934ddcdde749e3ba90a45a7 (diff)
downloadmemcached-c25d0bd68ab0f6226c2d979bf0951923624926dd.tar.gz
thread: use eventfd for worker notify if available
now that all of the read/writes to the notify pipe are in one place, we can easily use linux eventfd if available. This also allows batching events so we're not firing the same notifier constantly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index be2b460..0985f07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -644,6 +644,7 @@ AC_CHECK_FUNCS(memcntl)
AC_CHECK_FUNCS(clock_gettime)
AC_CHECK_FUNCS(preadv)
AC_CHECK_FUNCS(pread)
+AC_CHECK_FUNCS(eventfd)
AC_CHECK_FUNCS([accept4], [AC_DEFINE(HAVE_ACCEPT4, 1, [Define to 1 if support accept4])])
AC_CHECK_FUNCS([getopt_long], [AC_DEFINE(HAVE_GETOPT_LONG, 1, [Define to 1 if support getopt_long])])