summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2017-10-18 00:42:58 -0700
committerdormando <dormando@rydia.net>2017-11-28 14:18:05 -0800
commitcd2ce96754ef10926057dd76a203325c35384074 (patch)
treee2ff6c331a61887a43693a464b33601c56418e22 /configure.ac
parent603c1bb32304b107b468dae00ef083de1189762f (diff)
downloadmemcached-cd2ce96754ef10926057dd76a203325c35384074.tar.gz
extstore: configure and start time gating
./configure --enable-extstore to compile the feature in specify -o ext_path=/whatever to start.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca51927..9f05cfa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -82,6 +82,9 @@ fi
AM_PROG_CC_C_O
AC_PROG_INSTALL
+AC_ARG_ENABLE(extstore,
+ [AS_HELP_STRING([--enable-extstore], [Enable external storage EXPERIMENTAL ])])
+
AC_ARG_ENABLE(seccomp,
[AS_HELP_STRING([--enable-seccomp],[Enable seccomp restrictions])])
@@ -156,9 +159,14 @@ if test "x$enable_dtrace" = "xyes"; then
fi
fi
+if test "x$enable_extstore" = "xyes"; then
+ AC_DEFINE([EXTSTORE],1,[Set to nonzero if you want to enable extstorextstore])
+fi
+
AM_CONDITIONAL([BUILD_DTRACE],[test "$build_dtrace" = "yes"])
AM_CONDITIONAL([DTRACE_INSTRUMENT_OBJ],[test "$dtrace_instrument_obj" = "yes"])
AM_CONDITIONAL([ENABLE_SASL],[test "$enable_sasl" = "yes"])
+AM_CONDITIONAL([ENABLE_EXTSTORE],[test "$enable_extstore" = "yes"])
AC_SUBST(DTRACE)
AC_SUBST(DTRACEFLAGS)