summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDustin Sallings <dustin@spy.net>2012-02-01 00:11:17 -0800
committerdormando <dormando@rydia.net>2012-02-01 22:01:29 -0800
commitdece7f87e789f35311bfab785fcd9a063ead1afd (patch)
tree545762246449558168f96109d9a909759e7af0f1 /configure.ac
parentc1c99c9f2b37071ee46310735b7a1903aa53193c (diff)
downloadmemcached-dece7f87e789f35311bfab785fcd9a063ead1afd.tar.gz
Better detection of sasl_callback_ft
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31f1f9d..9915a46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,6 +302,33 @@ AH_BOTTOM([#ifdef HAVE_INTTYPES_H
])
dnl **********************************************************************
+dnl Figure out if this system has the stupid sasl_callback_ft
+dnl **********************************************************************
+
+AC_DEFUN([AC_HAVE_SASL_CALLBACK_FT],
+[AC_CACHE_CHECK(for sasl_callback_ft, ac_cv_has_sasl_callback_ft,
+[
+ AC_TRY_COMPILE([
+ #ifdef HAVE_SASL_SASL_H
+ #include <sasl/sasl.h>
+ #include <sasl/saslplug.h>
+ #endif
+ ],[
+ sasl_callback_ft a_callback;
+ ],[
+ ac_cv_has_sasl_callback_ft=yes
+ ],[
+ ac_cv_has_sasl_callback_ft=no
+ ])
+])
+if test $ac_cv_has_sasl_callback_ft = yes; then
+ AC_DEFINE(HAVE_SASL_CALLBACK_FT, 1, [we have sasl_callback_ft])
+fi
+])
+
+AC_HAVE_SASL_CALLBACK_FT
+
+dnl **********************************************************************
dnl DETECT_UINT64_SUPPORT
dnl
dnl check if we can use a uint64_t