summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTrond Norbye <Trond.Norbye@sun.com>2009-03-04 13:48:21 +0100
committerTrond Norbye <Trond.Norbye@sun.com>2009-03-04 13:48:21 +0100
commitf181a24d08a52629c897bf9070480054af159380 (patch)
tree783007305b1868285c129b26b4604fd3e52d94a7 /configure.ac
parenteffae30eec5a53d069ffc439979d05c7dbacac71 (diff)
downloadmemcached-f181a24d08a52629c897bf9070480054af159380.tar.gz
Detect xml2rfc and xsltproc during configure and generate the documentation as part of make
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6deed86..1e1c495 100644
--- a/configure.ac
+++ b/configure.ac
@@ -319,6 +319,10 @@ AC_CHECK_FUNCS(setppriv, [
AM_CONDITIONAL([BUILD_SOLARIS_PRIVS],[test "$build_solaris_privs" = "yes"])
+AC_PATH_PROG([XML2RFC], [xml2rfc], "no")
+AC_PATH_PROG([XSLTPROC], [xsltproc], "no")
+AM_CONDITIONAL([BUILD_SPECIFICATIONS],[test "x$XML2RFC" != "xno" -a "x$XSLTPROC" != "xno"])
+
dnl Let the compiler be a bit more picky. Please note that you cannot
dnl specify these flags to the compiler before AC_CHECK_FUNCS, because
dnl the test program will generate a compilation warning and hence fail