summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authordormando <dormando@rydia.net>2022-08-25 14:27:48 -0700
committerdormando <dormando@rydia.net>2022-08-25 14:27:48 -0700
commit0fd38f9986795f41fe7b8a4191789c52db953da0 (patch)
tree1ea2720021917dfa52ddd02fafbce61b76eb5b2a /doc/Makefile.am
parentcfe751ef9fa05b19ec70d4314718d1b3df23f38c (diff)
downloadmemcached-0fd38f9986795f41fe7b8a4191789c52db953da0.tar.gz
docs: don't rebuild binprot XML anymore
xml2rfc's toolchain has bitrotted and I don't intend on changing the binary protocol documentation anymore. Instead I've included the .txt files from 1.6.16 and commented out the build docs. Even if I adjust the call args for xml2rfc it complains about the copyright being old and I don't want to think about that :(
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am30
1 files changed, 15 insertions, 15 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 3539fc8..5359daa 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -10,24 +10,24 @@ EXTRA_DIST += $(SPECIFICATIONS)
BUILT_SOURCES =
MOSTLYCLEANFILES =
-if BUILD_SPECIFICATIONS
-BUILT_SOURCES += $(SPECIFICATIONS)
-MOSTLYCLEANFILES += $(SPECIFICATIONS)
-endif
+#if BUILD_SPECIFICATIONS
+#BUILT_SOURCES += $(SPECIFICATIONS)
+#MOSTLYCLEANFILES += $(SPECIFICATIONS)
+#endif
-RFC2629_XSL = $(srcdir)/xml2rfc/rfc2629-noinc.xsl
-RFC2629_DTD = $(srcdir)/xml2rfc/rfc2629.dtd
+#RFC2629_XSL = $(srcdir)/xml2rfc/rfc2629-noinc.xsl
+#RFC2629_DTD = $(srcdir)/xml2rfc/rfc2629.dtd
-%.txt: %.full $(RFC2629_DTD)
- @XML2RFC@ -d $(RFC2629_DTD) -c $(builddir) $< $@
-
-%.full: %.xml $(RFC2629_XSL)
- @XSLTPROC@ --nonet $(RFC2629_XSL) $< > $@
+#%.txt: %.full $(RFC2629_DTD)
+# @XML2RFC@ -d $(RFC2629_DTD) -c $(builddir) $< $@
+#
+#%.full: %.xml $(RFC2629_XSL)
+# @XSLTPROC@ --nonet $(RFC2629_XSL) $< > $@
# Prevent make from deleting intermediate files
-all-full: $(SPECIFICATIONS:.txt=.full)
+#all-full: $(SPECIFICATIONS:.txt=.full)
-clean-local:
- rm -f $(SPECIFICATIONS:.txt=.full)
+#clean-local:
+# rm -f $(SPECIFICATIONS:.txt=.full)
-.PHONY: all-full
+#.PHONY: all-full