summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am41
1 files changed, 27 insertions, 14 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 484bf9a..daee615 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -1,23 +1,36 @@
man_MANS = memcached.1
-EXTRA_DIST = *.txt
-
-BUILT_SOURCES=
-
+SPECIFICATIONS = protocol-binary.txt protocol-binary-range.txt
+
+EXTRA_DIST = new_lru.txt \
+ protocol.txt \
+ readme.txt \
+ storage.txt \
+ threads.txt \
+ tls.txt
+# When we make dist always include the generated specifications so people don't
+# have to have xml2rfc and xsltproc installed
+EXTRA_DIST += $(SPECIFICATIONS)
+
+BUILT_SOURCES =
+MOSTLYCLEANFILES =
if BUILD_SPECIFICATIONS
-BUILT_SOURCES += protocol-binary.txt protocol-binary-range.txt
-MOSTLYCLEANFILES = protocol-binary.txt protocol-binary-range.txt
+BUILT_SOURCES += $(SPECIFICATIONS)
+MOSTLYCLEANFILES += $(SPECIFICATIONS)
endif
-protocol-binary.txt: protocol-binary.full
- @XML2RFC@ -c @abs_builddir@ protocol-binary.full $@
+RFC2629_XSL = $(srcdir)/xml2rfc/rfc2629-noinc.xsl
+
+%.txt: %.full
+ @XML2RFC@ -c $(builddir) $< $@
-protocol-binary-range.txt: protocol-binary-range.full
- @XML2RFC@ -c @abs_builddir@ protocol-binary-range.full $@
+%.full: %.xml $(RFC2629_XSL)
+ @XSLTPROC@ --nonet $(RFC2629_XSL) $< > $@
-protocol-binary.full: protocol-binary.xml xml2rfc/rfc2629-noinc.xsl
- @XSLTPROC@ --nonet xml2rfc/rfc2629-noinc.xsl protocol-binary.xml > $@
+# Prevent make from deleting intermediate files
+all-full: $(SPECIFICATIONS:.txt=.full)
-protocol-binary-range.full: protocol-binary-range.xml xml2rfc/rfc2629-noinc.xsl
- @XSLTPROC@ --nonet xml2rfc/rfc2629-noinc.xsl protocol-binary-range.xml > $@
+clean-local:
+ rm -f $(SPECIFICATIONS:.txt=.full)
+.PHONY: all-full