summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@hera>2011-11-24 21:40:57 +0000
committerJose Fonseca <jfonseca@hera>2011-11-24 21:40:57 +0000
commit1983ede372d373169c4c1b51f59be044a710f714 (patch)
tree50e365b70685d386c5090511daa7f8e9fad7c6d3 /CMakeLists.txt
parentfae1335e05505e7a7b22491e581e5d36cbda2f03 (diff)
downloadmesa-demos-1983ede372d373169c4c1b51f59be044a710f714.tar.gz
cmake: Build the remainder of egl subtree.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d07215f0..90a98417 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,12 +2,12 @@ cmake_minimum_required (VERSION 2.8)
project (mesademos)
+include (FindPkgConfig)
+
find_package (OpenGL REQUIRED)
find_package (GLUT REQUIRED)
find_package (X11)
-find_library(EGL_egl_LIBRARY EGL /usr/lib)
-
find_library (GLEW_glew_LIBRARY GLEW
/usr/lib
)
@@ -16,6 +16,13 @@ find_path (GLEW_INCLUDE_DIR GL/glew.h
/usr/include/GL
)
+if (NOT WIN32)
+ pkg_check_modules (EGL egl)
+ pkg_check_modules (GLESV1 glesv1_cm)
+ pkg_check_modules (GLESV2 glesv2)
+ pkg_check_modules (VG vg)
+endif ()
+
if (UNIX)
link_libraries(m)
endif (UNIX)