summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@igalia.com>2023-01-25 18:44:33 +0000
committerMarge Bot <emma+marge@anholt.net>2023-02-01 06:33:52 +0000
commit6291d4d33978f14e59e64a4b66ef92ee891babc3 (patch)
tree07cff836b63ca5084f2aed8739ea63a0d7f696ed /meson.build
parent10992256ddf54c8240ca10e290924636680f3c01 (diff)
downloadmesa-6291d4d33978f14e59e64a4b66ef92ee891babc3.tar.gz
meson: turn android-libbacktrace into a feature option
Signed-off-by: Eric Engestrom <eric@igalia.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20915>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build12
1 files changed, 4 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 4ecdd523ed5..acabbcdfc88 100644
--- a/meson.build
+++ b/meson.build
@@ -818,14 +818,10 @@ if with_android_stub and not with_platform_android
error('`-D android-stub=true` makes no sense without `-D platforms=android`')
endif
-if get_option('android-libbacktrace') == 'auto'
- with_libbacktrace = with_platform_android
-else
- with_libbacktrace = get_option('android-libbacktrace') == 'true'
- if with_libbacktrace and not with_platform_android
- error('`-D android-libbacktrace=true` makes no sense without `-D platforms=android`')
- endif
-endif
+with_libbacktrace = get_option('android-libbacktrace') \
+ .require(with_platform_android, error_message : '`-D android-libbacktrace=enabled` makes no sense without `-D platforms=android`') \
+ .disable_auto_if(not with_platform_android) \
+ .allowed()
if with_libbacktrace
cpp_args += '-DWITH_LIBBACKTRACE'