summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Dywan <christian@twotoasts.de>2018-09-13 00:00:25 +0200
committerGitHub <noreply@github.com>2018-09-13 00:00:25 +0200
commitee3994177ab7d732aed829442c87779d9e5f9ee4 (patch)
tree0a95d6b8a1e379be660401c012c5c92611c0e66b /CMakeLists.txt
parent1245e9cd5603d0fe6e27c84d4a386bd5c47c9e0f (diff)
downloadmidori-git-ee3994177ab7d732aed829442c87779d9e5f9ee4.tar.gz
Configure exact user agent to reduce fingerprinting (#49)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c1ae0918..b12a05a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,6 +68,9 @@ set(CFLAGS "${CFLAGS} -g")
set(VALA_CFLAGS "-g -fPIC -w -Werror")
set(LIBCORE "${CMAKE_PROJECT_NAME}-core")
+set(CORE_OS "(X11; Linux x86_64)")
+set(CORE_ENGINE "AppleWebKit/537.36 (KHTML, like Gecko) Chrome/68.0.3440.106 Safari/537.36")
+set(CORE_USER_AGENT "Mozilla/5.0 ${CORE_OS} ${CORE_ENGINE} Midori/6")
configure_file(config.h.in config.h @ONLY)