summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Dywan <christian.dywan@canonical.com>2013-10-28 23:14:55 +0100
committerChristian Dywan <christian.dywan@canonical.com>2013-10-28 23:14:55 +0100
commit544d127d29c32f59f02f1e21c4e7d5527998aeab (patch)
tree8d81fa90b980da0037a7ee6075855d1cb0d76eab /CMakeLists.txt
parent8fa7a6b6a8353673e3ab229a68aa6edf711faa5b (diff)
downloadmidori-544d127d29c32f59f02f1e21c4e7d5527998aeab.tar.gz
C and Vala need to agree on the assumed libsoup version
Specifically the unit tests fail otherwise
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa0199b0..71390117 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -122,10 +122,10 @@ if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.37.1")
add_definitions("-DHAVE_LIBSOUP_2_37_1")
endif ()
if (${DEPS_libsoup-gnome-2.4_VERSION} VERSION_GREATER "2.40.0")
- add_definitions("-DHAVE_LIBSOUP_2_40_0")
# valac 0.16 didn't have the bindings yet
- message(STATUS "vala: ${VALA_VERSION}")
+ # For consistency we need to ensure C code makes the same assumptions
if (${VALA_VERSION} VERSION_GREATER "0.17.0")
+ add_definitions("-DHAVE_LIBSOUP_2_40_0")
set(VALAFLAGS ${VALAFLAGS} -D HAVE_LIBSOUP_2_40_0)
endif ()
endif ()