summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2019-05-28 14:48:42 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2019-05-28 14:48:42 +0200
commit52ff4f42c52166dafa7e619f95f458c9e3873165 (patch)
tree319da3a3a4bf11163ce77b5313e09d6696b2f6db /Makefile.am
parentd5cf9430ae338686f959d5071fced435ab8780b6 (diff)
downloadmm-common-52ff4f42c52166dafa7e619f95f458c9e3873165.tar.gz
Rename directory build/ to am_include/
This is in preparation for building mm-common with meson in the near future. When jhbuild is used for building a module with meson, and the user has requested builddir==srcdir, which meson forbids, jhbuild creates a $srcdir/build directory and builds there, even if there already is such a directory, used for other purposes.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fe0f3d..49858c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,10 +25,10 @@ man1_MANS = util/mm-common-prepare.1
# into projects at autogen.sh time:
build_supportdir = $(pkgdatadir)/build
dist_build_support_DATA = \
- build/compile-binding.am \
- build/dist-changelog.am \
- build/doc-reference.am \
- build/generate-binding.am
+ am_include/compile-binding.am \
+ am_include/dist-changelog.am \
+ am_include/doc-reference.am \
+ am_include/generate-binding.am
# These are installed so that aclocal can copy them into aclocal.m4
# at autogen.sh time:
@@ -45,7 +45,7 @@ dist_aclocal_macro_DATA = \
# These are installed so that mm-common-prepare can copy them into projects
# at autogen.sh time if a directory path is given to MM_CONFIG_DOCTOOL_DIR(),
-# or they can be found via pkg-config --variable=doctooldir mm-common,
+# or they can be found via pkg-config --variable=doctooldir mm-common-util,
# which is preferrable.
doctooldir = $(pkgdatadir)/doctool
dist_doctool_DATA = \
@@ -165,7 +165,7 @@ util/mm-common-prepare.1: $(srcdir)/util/mm-common-prepare.1.in Makefile
skeletonmm.tar.gz: $(skeletonmm_files)
$(AM_V_GEN)($(srctar_stdout) $(skeletonmm_files)) | gzip -c -n >$@
-include $(top_srcdir)/build/dist-changelog.am
+include $(top_srcdir)/am_include/dist-changelog.am
install-data-hook: $(if $(DESTDIR),,postinst-acdir-notice)