summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-08-06 11:25:49 +0200
committerDaniel Elstner <danielk@openismus.com>2009-08-06 11:25:49 +0200
commitce360da0551d45039c80b5ac9a390c4e5f671db9 (patch)
treefec61577193900e2f4fb07e4fbc5648e798aaf24 /Makefile.am
parent682c543bd653eaa3eff359d9d565f7c5dcda39d1 (diff)
downloadmm-common-ce360da0551d45039c80b5ac9a390c4e5f671db9.tar.gz
Handle multiple make targets correctly
* Makefile.am (check_updates): Modify the conditional expression so that it will trigger the update if any of the make targets specified on the command line starts with "all".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 759e47d..43c97e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -62,7 +62,7 @@ download_wget = $(WGET) -N -nd -T 300 -t 5 -P '$(@D)'
# If maintainer mode is enabled, always check the remote locations
# of the tag files for updates when building the default target.
if MAINTAINER_MODE
-check_updates = $(if $(MAKECMDGOALS:all%=),,$(dist_doxygen_tags_DATA))
+check_updates = $(if $(filter all%,$(or $(MAKECMDGOALS),all)),$(dist_doxygen_tags_DATA))
else
check_updates =
endif