summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2019-09-28 11:04:37 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2019-09-28 11:04:37 +0200
commitd28031cb786107c8a4400008ee2e41635ddea992 (patch)
treed001bc3f1e4a7da3f0c875300b534de0566d9af2 /Makefile.am
parent532d7a4218b43859db36b12b3a87e59ffb90a1f6 (diff)
downloadmm-common-d28031cb786107c8a4400008ee2e41635ddea992.tar.gz
Support modules that are built with Meson
* configure.ac: * Makefile.am: * meson.build: Install files from util/build_scripts/. Configure mm-common-get and mm-common-get.1. * README: Describe the new files. * util/build_scripts/*.py: * util/mm-common-get.1.in: * util/mm-common-get.in: New files for modules built with Meson. * util/mm-common-prepare.1.in: * util/mm-common-prepare.in: Mention that these are used for modules built with Autotools. See MR !2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 16 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b59a9f..1cd5df1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,17 +18,22 @@
# Pick up aclocal flags from the environment.
ACLOCAL_AMFLAGS = ${ACLOCAL_FLAGS}
-bin_SCRIPTS = util/mm-common-prepare
-man1_MANS = util/mm-common-prepare.1
+bin_SCRIPTS = util/mm-common-prepare util/mm-common-get
+man1_MANS = util/mm-common-prepare.1 util/mm-common-get.1
-# These are installed so that mm-common-prepare can copy them
-# into projects at autogen.sh time:
+# These are installed so that mm-common-prepare can copy the .am files
+# into projects at autogen.sh time, and mm-common-get can copy the .py files
+# at Meson setup or configure time:
build_supportdir = $(pkgdatadir)/build
dist_build_support_DATA = \
am_include/compile-binding.am \
am_include/dist-changelog.am \
am_include/doc-reference.am \
- am_include/generate-binding.am
+ am_include/generate-binding.am \
+ util/build_scripts/dist-build-scripts.py \
+ util/build_scripts/dist-changelog.py \
+ util/build_scripts/doc-reference.py \
+ util/build_scripts/generate-binding.py
# These are installed so that aclocal can copy them into aclocal.m4
# at autogen.sh time:
@@ -47,6 +52,7 @@ dist_aclocal_macro_DATA = \
# at autogen.sh time if a directory path is given to MM_CONFIG_DOCTOOL_DIR(),
# or they can be found via pkg-config --variable=doctooldir mm-common-util,
# which is preferrable.
+# mm-common-get can copy them at Meson setup or configure time.
doctooldir = $(pkgdatadir)/doctool
dist_doctool_DATA = \
util/doc-install.pl \
@@ -118,7 +124,7 @@ skeletonmm_script_files = \
skeletonmm_files = $(skeletonmm_script_files) $(skeletonmm_data_files)
-dist_noinst_DATA = util/mm-common-prepare.1.in $(skeletonmm_data_files)
+dist_noinst_DATA = util/mm-common-prepare.1.in util/mm-common-get.1.in $(skeletonmm_data_files)
dist_noinst_SCRIPTS = autogen.sh $(skeletonmm_script_files)
CLEANFILES = $(man1_MANS) $(doc_DATA)
@@ -170,6 +176,10 @@ doctags/libstdc++.tag:
util/mm-common-prepare.1: $(srcdir)/util/mm-common-prepare.1.in Makefile
$(AM_V_GEN)$(subst_manpage) $(srcdir)/util/mm-common-prepare.1.in >$@
+# Build the mm-common-get(1) manual page.
+util/mm-common-get.1: $(srcdir)/util/mm-common-get.1.in Makefile
+ $(AM_V_GEN)$(subst_manpage) $(srcdir)/util/mm-common-get.1.in >$@
+
# Create tar archive of skeletonmm for installation.
skeletonmm.tar.gz: $(skeletonmm_files)
$(AM_V_GEN)($(srctar_stdout) $(skeletonmm_files)) | gzip -c -n >$@