summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Elstner <danielk@openismus.com>2009-09-18 09:15:41 +0200
committerDaniel Elstner <danielk@openismus.com>2009-09-18 09:15:41 +0200
commite3c12fd65b65eb26003f93be52174ae4d17a9d27 (patch)
tree92ebc32b397c298a474f29b9ea611b0ad5aa4152 /Makefile.am
parenta48966794c9d04f013f2d90bb430c5a75e640575 (diff)
downloadmm-common-e3c12fd65b65eb26003f93be52174ae4d17a9d27.tar.gz
Remove pointless quotes from build commands
* Makefile.am: Remove single quotes around variable substitutions where all possible values are known to not contain meta-characters or whitespace.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 88669a7..c2c7bf4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -108,8 +108,8 @@ libstdcxx_tag_url = http://gcc.gnu.org/onlinedocs/libstdc++/latest-doxygen/libst
# Commands for downloading a target from a remote location, taking care
# not to download a file again if its time stamp has not changed.
download_curl = $(CURL) --compressed --connect-timeout 300 -g -L -m 3600 -R --retry 5 \
- $(if $(wildcard $@),-z '$@') -o '$@'
-download_wget = $(WGET) -N -nd -T 300 -t 5 -P '$(dir $@)'
+ $(if $(wildcard $@),-z $@) -o $@
+download_wget = $(WGET) -N -nd -T 300 -t 5 -P $(dir $@)
subst_manpage = $(SED) 's|[@]PACKAGE_STRING[@]|$(PACKAGE_STRING)|g;s|[@]docdir[@]|$(docdir)|g'
@@ -129,7 +129,7 @@ endif
# Download the libstdc++ tag file from the GCC website.
doctags/libstdc++.tag:
$(if $(CURL),$(download_curl) '$(libstdcxx_tag_url)',$(if\
- $(WGET),$(download_wget) '$(libstdcxx_tag_url)',test -f '$@'))
+ $(WGET),$(download_wget) '$(libstdcxx_tag_url)',test -f $@))
# Build the mm-common-prepare(1) manual page.
util/mm-common-prepare.1: $(srcdir)/util/mm-common-prepare.1.in Makefile