summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 4 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 3255328..fbc7e5e 100644
--- a/meson.build
+++ b/meson.build
@@ -274,10 +274,11 @@ install_data('README', install_dir: install_docdir)
download_cmd = 'none'
if get_option('use-network')
curl = find_program('curl', required: false)
- download_cmd = 'curl'
- if not curl.found()
+ if curl.found()
+ download_cmd = curl.path()
+ else
wget = find_program('wget', required: true)
- download_cmd = 'wget'
+ download_cmd = wget.path()
endif
endif