summaryrefslogtreecommitdiff
path: root/debian/mongodb-org-unstable.rules
diff options
context:
space:
mode:
authorErnie Hershey <ernie.hershey@10gen.com>2013-10-07 18:54:29 -0400
committerErnie Hershey <ernie.hershey@10gen.com>2013-10-12 18:20:01 -0400
commit31713e0af43e23ba6a46f44684d41877bebf0fde (patch)
tree50aff6b816a3ee7634701af54aa00f338ae3998a /debian/mongodb-org-unstable.rules
parentb57a0b403ef86071c2d8d8e8c32f54abb8907a75 (diff)
downloadmongo-31713e0af43e23ba6a46f44684d41877bebf0fde.tar.gz
SERVER-963 Separate enterprise and community debian rules and control files
Diffstat (limited to 'debian/mongodb-org-unstable.rules')
-rw-r--r--debian/mongodb-org-unstable.rules155
1 files changed, 155 insertions, 0 deletions
diff --git a/debian/mongodb-org-unstable.rules b/debian/mongodb-org-unstable.rules
new file mode 100644
index 00000000000..7ba9651507a
--- /dev/null
+++ b/debian/mongodb-org-unstable.rules
@@ -0,0 +1,155 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+ # Add here commands to configure the package.
+
+ touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp
+ dh_testdir
+
+ # Add here commands to compile the package.
+# THE FOLLOWING LINE IS INTENTIONALLY COMMENTED.
+ # scons
+ #docbook-to-man debian/mongodb.sgml > mongodb.1
+ echo debian/bsondump.1 > debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongodump.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongoexport.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongofiles.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongoimport.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongooplog.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongoperf.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongorestore.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongosniff.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongostat.1 >> debian/mongodb-org-unstable-tools.manpages
+ echo debian/mongotop.1 >> debian/mongodb-org-unstable-tools.manpages
+
+ echo debian/mongo.1 > debian/mongodb-org-unstable-shell.manpages
+ echo debian/mongod.1 > debian/mongodb-org-unstable-server.manpages
+ echo debian/mongos.1 > debian/mongodb-org-unstable-mongos.manpages
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp configure-stamp
+
+ # FIXME: scons freaks out at the presence of target files
+ # under debian/mongodb.
+ #scons -c
+
+ rm -f debian/*.manpages
+
+ rm -rf $(CURDIR)/debian/mongodb-org-unstable
+ rm -rf $(CURDIR)/debian/mongodb-org-unstable-shell
+ rm -rf $(CURDIR)/debian/mongodb-org-unstable-server
+ rm -rf $(CURDIR)/debian/mongodb-org-unstable-mongos
+ rm -rf $(CURDIR)/debian/mongodb-org-unstable-tools
+ rm -f config.log
+ rm -f mongo
+ rm -f mongod
+ rm -f mongoimportjson
+ rm -f mongoexport
+ rm -f mongorestore
+ rm -f mongodump
+ rm -f mongofiles
+ rm -f .sconsign.dblite
+ rm -f libmongoclient.a
+ rm -rf client/*.o
+ rm -rf tools/*.o
+ rm -rf shell/*.o
+ rm -rf .sconf_temp
+ rm -f buildscripts/*.pyc
+ rm -f *.pyc
+ rm -f buildinfo.cpp
+ dh_clean debian/files
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_prep
+ dh_installdirs
+
+# THE FOLLOWING LINE IS INTENTIONALLY COMMENTED.
+ # scons --prefix=$(CURDIR)/debian/mongodb/usr install
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-shell/usr/bin
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-server/usr/bin
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-mongos/usr/bin
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongo $(CURDIR)/debian/mongodb-org-unstable-shell/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongod $(CURDIR)/debian/mongodb-org-unstable-server/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongos $(CURDIR)/debian/mongodb-org-unstable-mongos/usr/bin
+
+ cp -v $(CURDIR)/BINARIES/usr/bin/bsondump $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongodump $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongoexport $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongofiles $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongoimport $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongooplog $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongoperf $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongorestore $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongostat $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+ cp -v $(CURDIR)/BINARIES/usr/bin/mongotop $(CURDIR)/debian/mongodb-org-unstable-tools/usr/bin
+
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-server/etc
+ cp $(CURDIR)/debian/mongod.conf $(CURDIR)/debian/mongodb-org-unstable-server/etc/mongod.conf
+
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-shell/usr/share/lintian/overrides/
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-server/usr/share/lintian/overrides/
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-mongos/usr/share/lintian/overrides/
+ mkdir -p $(CURDIR)/debian/mongodb-org-unstable-tools/usr/share/lintian/overrides/
+ install -m 644 $(CURDIR)/debian/lintian-overrides $(CURDIR)/debian/mongodb-org-unstable-shell/usr/share/lintian/overrides/mongodb-org-unstable-shell
+ install -m 644 $(CURDIR)/debian/lintian-overrides $(CURDIR)/debian/mongodb-org-unstable-server/usr/share/lintian/overrides/mongodb-org-unstable-server
+ install -m 644 $(CURDIR)/debian/lintian-overrides $(CURDIR)/debian/mongodb-org-unstable-mongos/usr/share/lintian/overrides/mongodb-org-unstable-mongos
+ install -m 644 $(CURDIR)/debian/lintian-overrides $(CURDIR)/debian/mongodb-org-unstable-tools/usr/share/lintian/overrides/mongodb-org-unstable-tools
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+ dh_installinit -pmongodb-org-unstable-server --name=mongod
+# dh_installinfo
+ dh_installman
+ dh_link
+# Appears to be broken on Ubuntu 11.10...?
+# dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure