summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRichard Kreuter <richard@10gen.com>2010-02-05 16:45:22 -0500
committerRichard Kreuter <richard@10gen.com>2010-02-05 16:45:40 -0500
commit5c5fd566404046f25bdc55f9ddbf9571ba03304b (patch)
tree04d359b7bf72b9fa01c5adb0a1c505a8f1b70608 /debian
parent294df23c007e26609240693c0adff2a8a1d46ed9 (diff)
downloadmongo-5c5fd566404046f25bdc55f9ddbf9571ba03304b.tar.gz
Try again at installing mongodb.conf in .deb packages MINOR
Diffstat (limited to 'debian')
-rw-r--r--debian/mongodb.conf88
-rw-r--r--debian/rules2
2 files changed, 89 insertions, 1 deletions
diff --git a/debian/mongodb.conf b/debian/mongodb.conf
new file mode 100644
index 00000000000..d1bc5956372
--- /dev/null
+++ b/debian/mongodb.conf
@@ -0,0 +1,88 @@
+# mongodb.conf
+
+#where to log
+logpath=/var/log/mongod
+
+logappend=true
+
+#port = 27017
+
+dbpath=/var/lib/mongo
+
+# Enables periodic logging of CPU utilization and I/O wait
+#cpu = true
+
+# Turn on/off security. Off is currently the default
+#noauth = true
+#auth = true
+
+# Verbose logging output.
+#verbose = true
+
+# Inspect all client data for validity on receipt (useful for
+# developing drivers)
+#objcheck = true
+
+# Enable db quota management
+#quota = true
+
+# Set oplogging level where n is
+# 0=off (default)
+# 1=W
+# 2=R
+# 3=both
+# 7=W+some reads
+#oplog = 0
+
+# Diagnostic/debugging option
+#nocursors = true
+
+# Ignore query hints
+#nohints = true
+
+# Disable the HTTP interface (Defaults to localhost:27018).
+#nohttpinterface = true
+
+# Turns off server-side scripting. This will result in greatly limited
+# functionality
+#noscripting = true
+
+# Turns off table scans. Any query that would do a table scan fails.
+#notablescan = true
+
+# Disable data file preallocation.
+#noprealloc = true
+
+# Specify .ns file size for new databases.
+# nssize = <size>
+
+# Accout token for Mongo monitoring server.
+#mms-token = <token>
+
+# Server name for Mongo monitoring server.
+#mms-name = <server-name>
+
+# Ping interval for Mongo monitoring server.
+#mms-interval = <seconds>
+
+# Replication Options
+
+# in replicated mongo databases, specify here whether this is a slave or master
+#slave = true
+#source = master.example.com
+# Slave only: specify a single database to replicate
+#only = master.example.com
+# or
+#master = true
+#source = slave.example.com
+
+# Address of a server to pair with.
+#pairwith = <server:port>
+# Address of arbiter server.
+#arbiter = <server:port>
+# Automatically resync if slave data is stale
+#autoresync
+# Custom size for replication operation log.
+#oplogSize = <MB>
+# Size limit for in-memory storage of op ids.
+#opIdMem = <bytes>
diff --git a/debian/rules b/debian/rules
index 92d7a6f8117..f3706950f60 100644
--- a/debian/rules
+++ b/debian/rules
@@ -58,7 +58,7 @@ install: build
dh_installdirs
scons --prefix=$(CURDIR)/debian/mongodb/usr install
- #cp $(CURDIR)/debian/mongodb.conf $(CURDIR)/debian/mongodb/etc/mongodb.conf
+ cp $(CURDIR)/debian/mongodb.conf $(CURDIR)/debian/mongodb/etc/mongodb.conf
# Build architecture-independent files here.
binary-indep: build install