summaryrefslogtreecommitdiff
path: root/ext/test/fail_fs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/test/fail_fs/Makefile.am')
-rw-r--r--ext/test/fail_fs/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/ext/test/fail_fs/Makefile.am b/ext/test/fail_fs/Makefile.am
new file mode 100644
index 00000000000..f31f5395cd1
--- /dev/null
+++ b/ext/test/fail_fs/Makefile.am
@@ -0,0 +1,9 @@
+AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)/src/include
+
+noinst_LTLIBRARIES = libwiredtiger_fail_fs.la
+libwiredtiger_fail_fs_la_SOURCES = fail_fs.c
+
+# libtool hack: noinst_LTLIBRARIES turns off building shared libraries as well
+# as installation, it will only build static libraries. As far as I can tell,
+# the "approved" libtool way to turn them back on is by adding -rpath.
+libwiredtiger_fail_fs_la_LDFLAGS = -avoid-version -module -rpath /nowhere