| Commit message (Expand) | Author | Age | Files | Lines |
* | Make run-time statistics optional, defaulted to "off". | Keith Bostic | 2013-02-22 | 1 | -1/+2 |
* | Create a #define that initializes a static WT_CURSOR and use it. | Keith Bostic | 2013-01-08 | 1 | -0/+1 |
* | Minor cleanup, we're no longer using some of the WT_STAT_XXX #defines. | Keith Bostic | 2012-12-06 | 1 | -4/+2 |
* | Update shared_cache configuration settings and related changes. | Alex Gorrod | 2012-11-09 | 1 | -0/+1 |
* | unused #define | Michael Cahill | 2012-10-03 | 1 | -0/+1 |
* | Add autocommit to WT_SESSION::truncate. | Michael Cahill | 2012-09-21 | 1 | -0/+3 |
* | Checkpoint handles must be closed when they are overwritten. | Michael Cahill | 2012-07-26 | 1 | -0/+1 |
* | checking for unused #defines: WT_DEBUG_BYTE | Michael Cahill | 2012-05-29 | 1 | -0/+1 |
* | update the unused #define list. | Keith Bostic | 2012-05-15 | 1 | -10/+0 |
* | Remove the config string from WT_CURSOR::close: it is no longer required and ... | Michael Cahill | 2012-02-02 | 1 | -1/+0 |
* | WT_CURSOR->close methods shouldn't return immediately if there's bad | Keith Bostic | 2012-02-01 | 1 | -0/+1 |
* | update, block no longer uses TAILQs for the free list. | Keith Bostic | 2012-01-26 | 1 | -0/+5 |
* | Rework statistics cursors (issue #135). | Keith Bostic | 2012-01-19 | 1 | -0/+8 |
* | Now that there is a constant for the maximum size of a packed integer, use it. | Michael Cahill | 2011-12-19 | 1 | -1/+1 |
* | Restructure reads to not use serialized functions, reduce the number of calls... | Michael Cahill | 2011-12-12 | 1 | -0/+2 |
* | Overlapping subtrees are expected with parallel eviction. Use a spinlock to ... | Michael Cahill | 2011-12-09 | 1 | -0/+1 |
* | Suppress a warning about an unused WT_STAT macro. | Michael Cahill | 2011-11-21 | 1 | -0/+1 |
* | Rename WT_MTX to WT_CONDVAR | Michael Cahill | 2011-11-04 | 1 | -1/+0 |
* | Add implementations of spinlocks based on POSIX thread mutexes and GCC intrin... | Michael Cahill | 2011-10-06 | 1 | -0/+5 |
* | Update. | Keith Bostic | 2011-10-22 | 1 | -8/+12 |
* | Incorporate Keith's feedback on read/write barriers. | Michael Cahill | 2011-09-30 | 1 | -1/+0 |
* | Add read and write barriers plus macros to make their use easier. | Michael Cahill | 2011-09-28 | 1 | -0/+1 |
* | Add an extension API with a list of functions so extensions can call into Wir... | Michael Cahill | 2011-08-16 | 1 | -0/+1 |
* | Put inserted items on skiplists so we can do efficient searches (including fo... | Michael Cahill | 2011-07-29 | 1 | -0/+1 |
* | Add some more statistics to the reconciliation code as part of reviewing how | Keith Bostic | 2011-08-04 | 1 | -0/+1 |
* | Redo Paul Vixie's bitstring.h #defines as inline functions, using | Keith Bostic | 2011-08-03 | 1 | -8/+0 |
* | Remove the support for the fixed-length, RLE column-store format (this | Keith Bostic | 2011-07-21 | 1 | -1/+0 |
* | Change the WT_IKEY's disk-page value-cell offset to be a key-cell | Keith Bostic | 2011-06-02 | 1 | -1/+0 |
* | Check inlined code when looking for unused macros. | Michael Cahill | 2011-05-24 | 1 | -6/+3 |
* | Remove some s_all output: remove some macros we no longer need. | Michael Cahill | 2011-05-09 | 1 | -1/+4 |
* | Rewrite RLE file format to use WT_INSERT structures instead of WT_RLE_EXPAND | Keith Bostic | 2011-03-28 | 1 | -2/+0 |
* | WT_PAGE_DISK_REF is used in btree.h | Keith Bostic | 2011-03-08 | 1 | -0/+1 |
* | Checking for unused #defines ... | Michael Cahill | 2011-02-08 | 1 | -1/+0 |
* | We're using TAILQ_LAST in the code, now. | Keith Bostic | 2011-02-04 | 1 | -1/+0 |
* | We're using TAILQ_FOREACH_REVERSE and TAILQ_INSERT_BEFORE now. | Keith Bostic | 2011-02-03 | 1 | -2/+0 |
* | Merge the build of the WiredTiger core with the API tree. | Michael Cahill | 2011-02-01 | 1 | -0/+2 |
* | Delete the entire page addr/size cache, and replace it with an in-memory tree. | Keith Bostic | 2011-01-11 | 1 | -2/+2 |
* | Remove the whole FLIST (free-list) structure support, we're no longer freeing | Keith Bostic | 2010-07-24 | 1 | -1/+0 |
* | Update | Keith Bostic | 2010-07-17 | 1 | -1/+2 |
* | Don't pretend to generate statistics for the {Env,Db}.{err,errx} method calls, | Keith Bostic | 2010-04-16 | 1 | -4/+0 |
* | Move "descriptor" record into a sector of its own, the first 512 bytes of the | Keith Bostic | 2010-04-15 | 1 | -1/+0 |
* | Statistics may not be initialized when {ENV,DB}.{err,errx} called, don't track. | Keith Bostic | 2010-04-14 | 1 | -0/+5 |
* | Add stat increments for DB_ERR/DB_ERRX, ENV_ERR/ENV_ERRX. | Keith Bostic | 2010-04-07 | 1 | -0/+1 |
* | Update. | Keith Bostic | 2010-04-06 | 1 | -0/+1 |
* | update. | Keith Bostic | 2010-03-26 | 1 | -1/+1 |
* | Add a script to display unused #defines. | Keith Bostic | 2010-02-15 | 1 | -0/+75 |