summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2008-04-09 10:47:19 +0000
committerthevenyp <thevenyp@211d60ee-9f03-0410-a15a-8952a2c7a4e4>2008-04-09 10:47:19 +0000
commit08edcef1c32fdc936f0b2a1e3d49317513145887 (patch)
tree7c77abc85f4e757e2bd3a02fe41557744a990565 /Makefile.am
parentafea999b442052808beb14b22f17252e67a2da8c (diff)
downloadmpc-08edcef1c32fdc936f0b2a1e3d49317513145887.tar.gz
File reorganisation into three new directories: src, tests and doc.
git-svn-id: svn://scm.gforge.inria.fr/svn/mpc/trunk@82 211d60ee-9f03-0410-a15a-8952a2c7a4e4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 2 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 620408c..4d5aeae 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,21 +1,6 @@
## Makefile.am -- Process this file with automake to produce Makefile.in
-include_HEADERS = mpc.h
+SUBDIRS = src tests
-lib_LTLIBRARIES = libmpc.la
-libmpc_la_SOURCES = mpc-impl.h abs.c add.c add_fr.c add_ui.c clear.c \
-cmp.c cmp_si_si.c conj.c cos.c div_2exp.c div.c div_fr.c div_ui.c exp.c \
-get_prec2.c get_prec.c init2.c init3.c init.c inp_str.c mul_2exp.c mul.c \
-mul_fr.c mul_i.c mul_si.c mul_ui.c neg.c norm.c out_str.c random2.c random.c \
-set.c set_d_d.c set_dfl_prec.c set_prec.c set_si_si.c set_ui_fr.c \
-set_ui_ui.c sin.c sqr.c sqrt.c sub.c sub_ui.c uceil_log2.c ui_div.c \
-ui_ui_sub.c
+include_HEADERS = $(top_srcdir)/src/mpc.h
-LDADD = $(top_builddir)/libmpc.la
-check_INCLUDES = -I$(top_srcdir)
-check_PROGRAMS = test tabs tcos tdiv texp tmul tsin tsqr
-
-TESTS = $(check_PROGRAMS)
-CLEANFILES = $(top_builddir)/mpc_test
-
-info_TEXINFOS = mpc.texi